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[bookmark: _Toc184566744]Introduction
After living with computer science majors for four years, I knew about every problem LaTeX had. From late night study sessions to lunchtime rants, I was made acutely aware of the coding language’s inability to format something as simple as a table. I was there to witness as my roommate dug up old chat rooms on the internet, seeking some coding solution to position a singular picture within their document. As they often told me, and as any computer science major will likely tell you: LaTeX, and its compilers, suck. 
During these rants, I often wondered if there could be an easier way to format proofs without using a forty-year-old coding language. Computer science majors may swear that LaTeX was the one and only solution to formatting reports and proofs, but what if there was another option? It was questions like these that led me to create this manual, to finally test if proofs could be formatted with software as simple as Microsoft Word.
In this manual, I attempt to outline everything I’ve seen in LaTeX documents after years of peering over my roommates’ shoulders. My sections are focused on formatting documents to appear as they would with LaTeX compilers, creating and adjusting inline and display math, and adding additional notation for clarification. With these modules, I hope to provide computer science students with instructions to create everything from DFA diagrams to adjusting margins using the 2410 version of Microsoft Word for Windows. And a bit selfishly, finally prove that computer science proofs can exist outside of LaTeX without any headaches.
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Chapter 1: Formatting Your Document



[bookmark: _Toc184566745]1.1 Formatting Your Margins
Margins created by Latex and subsequent compilers are large (about 1.5” on the left and right side when using 12 pt. font), creating a narrow field for the main body of proofs. In Word, you can achieve this desired appearance by customizing your margins. 
1. From the Ribbon, select Layout, then Margins. 
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2. Select Custom Margins. A new window opens. 
3. In the Left and Right sections, enter your new margin measurements. Most proofs use 1.8-inch margins.
Tip: Instead of Clicking OK when you’re done setting your margins, click Set As Default to ensure all your proofs will be formatted similarly in the future.  
4. Click OK when you’re done. 
[bookmark: _Toc184566746]1.2 Downloading and Using Latin Modern
In LaTeX, everything is typed in a font called Computer Modern. While this font isn’t readily available on Word, you can download Latin Modern, a similar font, to Word. 
1. Go to: https://www.ctan.org/tex-archive/fonts/lm/fonts/opentype/public/lm/. This site has the Latin Modern font collection.
2. From there, you can download the following fonts:
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Having these fonts can ensure that writing and formatting headings is a seamless process.
3. In your File Explorer, right-click on the fonts, and select Install. If your computer asks if the new program is allowed to make changes, select yes, as this is a safe download. 
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4. In the Home tab, go to the font drop-down menu. Latin Modern now appears in your font library as LM Roman 17 and LM Roman 12.
[bookmark: _Toc184566747]1.3 Finding Shortcuts for Blackboard and Calligraphy
Computer science proofs use different fonts to indicate different objects and functions. Proof writers use Blackboard for groups of numbers, Calligraphy for operators, and Bold for vectors. You can access more of these fonts by enabling Word’s shortcuts (both shortcuts recognize lowercase and uppercase letters and adapt accordingly). 
1. Go to Files then select Options. A window opens. 
2. In the Proofing section, select AutoCorrect Options. A separate window opens. 
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Description automatically generated] Tip: When you first open the Options window, it will drop you into the General tab, rather than the Proofing tab that’s pictured. Ensure you’re in the right tab when enabling AutoCorrect Options…


3. Select the Use Math Autocorrect rules outside of math regions and ensure that replace text as you type is checked. 
4. Select OK.
5. To type in Blackboard font, type “\double” with the desired letter typed at the end. Press the space bar once finished typing to activate the shortcut. 
\doublea  𝕒   or  \doubleA  𝔸 
6. To type in Script font, type “\script” with the desired letter typed at the end Press the space bar once finished typing to activate the shortcut. 
\scripta  𝒶   or  \scriptA  𝒜 
[bookmark: _Toc184566748][bookmark: _Hlk179207563]1.4 Setting Up Your Proof Headings with Styles
In your homework proofs, it’s important to include an informative title and additional headings to organize the problems within your document. To set up a proper computer science proof, it’s helpful to familiarize yourself with styles to obtain proper organization and emphasis. 
[image: A screenshot of a black background
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-title
-proof heading
-proof sub-heading


[bookmark: _Toc184566749]Formatting the Title
1. Type the class number and problem, your name, and the full date as you usually would, ensuring each is on a separate line.
2. Select the first line of text.
3. In the Styles section of the Home tab, select Title from the drop-down menu. The text changes in size and color.
4. With the first line still selected, you can change the font size to LM Roman 17, “17pt,” and black with the Font section of the Home tab to mimic a LaTeX document.
5. Select the next two lines and select Subtitle from the Styles menu.   
6. With these lines selected, you can achieve a similar look by changing the font size to LM Roman 12, “12pt,” and black using the method described in Step 4. 
7. Then, select the three lines center them using the Paragraph tab.

[bookmark: _Toc184566750]Formatting Proof Headings
1. Type the “Problem___” and the number of the problem set.
2. Select the text. 
3. In the Styles section, select Heading. The text changes in size and color.
4. Once again, you can change the selected to LM Roman 12, “14.5,” black, and bold using the Font section to match headers in LaTeX formatting.
5. Select the text once more, but this time right click on the Heading selection in the Style tab.
6. Click Update Heading 1 to Match Selection. This makes it so you don’t need to reformat following headers.
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[bookmark: _Toc184566751]Formatting Proof Subheadings
1. Type the problem number, the part number, and the question the proof is asking.
2. Select the text. 
3. In the Styles section of the Home tab, select Heading 2. The text changes in size and color.
4. You can now change the selection to LM Roman 12, “12pt,” black, and bold to imitate LaTeX subheads. 
5. Use the previously mentioned steps to update Heading 2 to match your current selection. 

[bookmark: _Toc184566752]1.5 Adding Page Numbers
Proof documents usually have page numbers that are centered on the bottom of the page. Thankfully, Word makes it simple for you to attain this look.
1. Go to the Insert tab.
2. Under the Header & Footer section, click the Page Number button.
3. Go to the Bottom of the Page option. A drop-down menu appears beside it.
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4. Select Plain Number 2. Your page numbers now appear centered at the bottom of the page. 
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Chapter 2: Inline and Display Math




[bookmark: _Toc184566753]2.1 Finding the Symbols You Need
There are a variety of symbols and variables used in computer science proofs from Greek letters to mathematical notation. However, you can access them all in the Insert tab. 

1. Go to the Insert tab. 
2. Click on Symbol. A drop-down menu appears.
3. Click More Symbols. A window appears. 
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4. Select your desired font from the Font drop-down.
5. Search for the symbol you need using the Subset drop-down menu, or by scrolling through the area below. 
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Description automatically generated] The Subset drop-down menu allows you to search symbols by subset categories.
The Font drop-down menu allows you select the font for these symbols.



6. When you’re finished, click Insert to add the symbol to your equation, or text.
[bookmark: _Toc184566754]2.2 How to Create Equations
Creating equations is crucial to writing computer science proofs, regardless of if it’s inline or display math. Thankfully, Word has a function that allows you to seamlessly insert functions into your document. 
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1. Go to the Insert Tab. 
2. Click the down arrow on Equation. A dropdown menu appears with a variety of pre-formatted equations you can choose to insert into your document.
3. If you don’t see the equation you need, navigate to the bottom of the dropdown menu and click More Equations from Office.com. This new dropdown menu provides you with even more equation options.
4. Once you find the equation you need, click on it to add it to the document.
5. Edit the equation as you see fit by clicking on the equation box. 

Inserting a Custom Equation
1. If you want to write your own equation, click on the Equation button. A drop-down menu appears.
2. Click Insert Equation. A new tab appears on the ribbon titled Equation and a box that reads Type equation here in the place of your cursor.  
3. Click LaTeX in the Conversion section. This allows you to type in LaTeX format. 
4. From there, you can alternate between typing your equation, or using the options provided in the Equation ribbon to insert equation structures and symbols. 
[bookmark: _Toc184566757]2.3 How to Create a Case Environment
Case environments are important for your computer science proofs as they outline the key cases of your equations or formulas. You can smoothly implement case environments into your proofs with Microsoft Word, especially once you’ve learned to use the equation function.

1. Insert an equation using the instructions from 2.2.
2. Go to the Equation tab. 
3. Click Bracket in the Structures section.
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4. Go to the Cases and Stacks section and select the Case (Two Conditions) or Case (Three Conditions) environment. 
Tip: After inserting and editing your equation, you can hit enter to add more conditions (if you have more conditions you need to add).

[image: A screenshot of a computer

Description automatically generated]

5. Once your case environment appears, you can use your arrow keys to move between the areas and type your cases. 
6. When you’re finished, click outside of the equation to stop editing.


[bookmark: _Toc184566758]2.4 How to Use Subscript and Superscript
Whether it’s creating DFA diagrams or writing math equations, subscript and superscript are used throughout proof writing. Luckily, you can access both through the ribbon and shortcuts.

[bookmark: _Toc184566759]Where to Find Subscript and Superscript on the Ribbon
1. Type the base text you’re attaching your subscript or superscript to. 
2. In the Font section under the Home tab, the Subscript and Superscript options are placed right next to each other. Click the script you need. The cursor shrinks, going to the top or bottom of the base text depending on your choice. 
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3. Type the word, letter, symbol, or number you want for your subscript or superscript.
4. When you’re done, click either the Subscript or Superscript option again (whatever choice you originally clicked on) to return to normal typing.

[bookmark: _Toc184566760]Shortcut for Subscript and Superscript
1. Type the base text you’re attaching your subscript or superscript to.
2. If you want to use subscript, you can press Ctrl, Shift, and - at the same time, or if you want to use superscript, you can press Ctrl, Shift, and + at the same time. The cursor shrinks accordingly.
3. Type the word, letter, symbol, or number you want for your subscript or superscript.
4. When you want to restore the cursor to its normal size, you can use the shortcut again to do so.

[bookmark: _Toc184566761]2.5 Formatting Align Environments
In computer science proofs, align environments are used to showcase the steps the student took to obtain the solution in their proof. To make it easier for the reader to follow these steps, it is formatted so each following line is aligned with the first equal sign. Using Microsoft Word, you can format your display math to mimic this alignment.

[bookmark: _Toc184566762]Creating Tab Stops
1. Write out your initial equation using the directions from 2.2.
2. Click anywhere on the ruler to create a tab stop. 
3. Click on the tab stop and drag it so it rests just before the equal sign in your equation. This ensures that every time you hit enter, your next equation aligns with the equal sign of the previous one. 
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4. Hit Enter then Tab on your keyboard to return to the same spot on the next line. 
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[bookmark: _Toc184566763]
Editing and Deleting Tab Stops
1. Navigate to the Paragraph section in the Home tab of the ribbon.
2. Click on the arrow in the corner. A window appears.
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3. Select Tabs… A new window appears.
4. If you’re looking to edit a tab stop, you can select the tab stop under the Tab stop position section, then type a new measurement. 
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This box is where you can change the measurement of the tab stop.

This box is where you can select which tab stop you’re editing.

5. If you’re looking to clear a tab stop, you can select the tab stop in the Tab stop position box then Clear.
6. If you’re looking to clear all tab stops, you can select Clear All.  
7. Select OK to finalize any of these edits.

[bookmark: _Toc184566764]2.6 How to Insert a Table
Tables are a useful tool in proofs for organizing and displaying important data, or data sets. Word makes adding and editing tables easily accessible and user friendly. 

1. Go to the Insert tab.
2. Click Table. A dropdown menu appears. 
3. Hover over the grid to decide the dimensions of your table. 
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4. When you’re finished, select the final, bottom-left cell to apply your dimensions and insert the table. Two new tabs appear on the ribbon: Table Design and Table Layout.
5. Input your data by clicking in the cells or use the two new tabs to style your data as you please.


[bookmark: _Toc184566765]2.7 Downloading Lucidchart
Computer science proofs require discrete structures and various other diagrams for proposed solutions and claims. Thankfully, Microsoft Word has an add-on called Lucidchart that can help you create this more complex display math. 

1. Go to File.
2. Click Get Add-ins. A new window opens.
3. Search “Lucidchart” in the store.
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Description automatically generated]Tip: Ensure you select Lucidchart Diagrams for Word. For these modules, Lucidscale Models for Word, is no use to you.



4. Click Add.
5. Accept the following terms and conditions. Once you have accepted, you are brought back to Word with a new side window open in the right margin.
[bookmark: _Toc184566766]2.8 How to Create DFA/NFA Diagrams
Deterministic Finite Automaton (DFA) diagrams and Nondeterministic Finite Automata (NFA) diagrams are common within computer science proofs across all levels. Lucidchart assists in creating these diagrams and positioning them within your document.

[bookmark: _Toc184566767]Creating Your Diagram
1. Launch Lucidchart in the Insert tab. The Lucidchart window opens on the right side of the screen.
2. Click Create New. A new window appears for Lucidchart
3. To start your chart, insert a circle from the Shapes. You can use these circles for your nodes, or states. 
4. To write inside your nodes, double-click on each circle. A cursor appears inside.  
5. If you want to connect the nodes, add Lines under the Standard section. You can use these lines to represent transitions. 
6. To modify the lines, select them, then navigate to the Line options in the ribbon.
7. Select the straight-line option or the curved-line option to format your transitions. 
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Text Options: This is where you can access subscript and superscript.

This is the Shapes tab; You may need to scroll to access more options.


[bookmark: _Toc184566768]Inserting and Positioning Your Diagram
1. When you’re finished with your diagram, go to File, then Save. 
2. Close the Lucidchart window and return to your Word document. 
3. Select Browse Diagrams in the Lucidchart window on the right side of the screen.
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4. Click on the diagram you saved then Select, to import the diagram into your document.
5. From there, you can format your diagram as you would a picture.
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[bookmark: _Toc184566769]2.9 How to Create Matrices
Matrices are grids of numbers used for data manipulation and transformation that frequently appear within proofs for computer science. The Lucidchart add-on can be used to format these arrangements.

1. Launch Lucidchart in the Insert tab. The Lucidchart window opens on the right side of the screen.
2. Click Create New. A new window appears for Lucidchart
3. Click on the Containers tab on the left sidebar in the window. 
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The Container tab is right beneath the Shapes tab.




This is what the Double Bracket option looks like.


4. Click on the Double Bracket. You can use this for the frame of your matrix.
5. Navigate back to the Shapes tab. 
6. Click Text in the Standard section of the left sidebar. 



7. Drag the textbox inside the matrix. This allows you to link the two components, so they’ll move together.

This is the Text feature.


Tip: While there is only one text box featured in the image, you may need more than one to establish rows.
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8. Once you have assured that the text box is properly formatted to your liking within the brackets, insert or type your data. 
9. When you’re finished with your matrix, go to File, then Save.
10. Close the Lucidchart window and return to your Word document. 
11. Select Browse Diagrams in the Lucidchart window on the right side of the screen.
12. Click on the diagram you saved, then Select to import the matrix into your document.
13. From there, you can format your matrix as you would a picture.
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Additional Notation


[bookmark: _Toc184566770]3.1 Adding Links to Theorems
Some computer science majors find it helpful to link certain parts of their proof back to a previously used theorem, especially if it appears throughout a document. Instead of typing it numerous times, you can link chosen text back to a previous iteration earlier in your document using the Bookmark tool.

[bookmark: _Toc184566771]Creating the Destination
1. Select the text you want to bookmark. 
2. In the Link section under the Insert tab, select Bookmark. A window appears.
 [image: A screenshot of a computer

Description automatically generated]After you type a proper name for your bookmark at the top of the window, the Add button lights up. Be careful when naming bookmarks, as no spaces are allowed. However, you can use underscores (_) in place of spacing

3. Type a name for your Bookmark.
4. Select Add. 
[bookmark: _Toc184566772]Creating the Link
1. Select the text you want to link to the bookmark you made.
2. Right-click on the selection and choose Link. A window appears.
3. On the left side of the window, select Place in This Document. 
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4. Select the bookmark you wish to link to, then OK.
[bookmark: _Toc184566773]
3.2 Labeling Figures
Labeling your equations and diagrams can make your document much more organized, and it provides a better way to reference them within the body of your proof. The caption function in Microsoft Word can help without breaking the formatting of your document. 

1. Select the object you want to caption.
2.  In the Reference tab, select Insert Caption in the Caption section.
3. Select Add New Source. A window appears. This box is where you can add a caption to the object.


This box is where you can select the label of the object.
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4. In the Options box, select what best describes the highlighted object. If you don’t see what you need, you can select New Label and enter in a new label option. 
5. In the Caption box, you can give your object a title.
6. Select OK. Your object now has a caption below it. 
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[bookmark: _Toc184566774]Colophon

This manual was printed by Collective Copies based out of Amherst, Massachusetts. It is a combination of gorgeous Microsoft Office fonts such as Arial Black and Aptos, as well as more whimsical Canva typefaces like Megapixel and Telegraf. The graphics used on the front cover, back cover, and chapter pages were designed by the author using Canva’s free resources. It may be the only manual in existence that was made using a Surface Laptop 5, Microsoft Word 2410, and the power of friendship.
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1 Problem 1

1.1 Ts every minimum-bottleneck tree a minimum spanning tree of G?

Answer: No. Prove by counterexample:

Figure 2: Counterexample to the claim. We can see that any minimumbottleneck tree
(MBT) for the graph on the left requires the edge ¢ G, as it is the minimum edge
that conneets G to the rest of the graph. This means the tree on the right is a valid
MBT. However, it doesn't include the edge S — [ which is the cheapest edge that
connects §'to the rest of the graph, 50 it isn’t a minimum spanning tree.

2.2 Is every minimum spanning tree a minimum-bottlencck tree of G?

Answer: True

Proof: Assume you can swap the maximum edge eyof a spanning tree for another
combination of edges such that the total weight remains unchanged, but the maximum
edge is reduced. By properties of spanning trecs, any edge added to it will ereate a cycle.
Morcover, because eyis the edge you want o remove, the cyclo must involve cuso that
it may be removed while preserving the spanning property of the trec. Append the edges
you want; to swap for eyto the spanning tree. Then, because the modified tree has a
cycle involving ey, and eyis the maximum edge in the graph, then by the cycle property
eyis not. part of any minimum spanning tree of the graph. This is a contradiction, as
eyis already part of a minimum spanning tree. So every minimum spanning tree s a
‘minimum bottlencck tree.
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